Most web browsers allow you to store passwords for easier and faster logging in to websites. We found a free tool, called IE PassView, that makes it easy to view, backup, and delete passwords saved in Internet Explorer.

IE PassView works with Internet Explorer versions 4.0 and above, through Internet Explorer 11 on Windows 10.

Download IE PassView from

http://www.nirsoft.net/utils/internet_explorer_password.html.

There are two versions of IE PassView you can download. The .exe file is a full installer with an uninstaller. The .zip file is a portable version of IE PassView.

IE PassView installation file

We chose to unzip the .zip file and use the portable version. To use this version, simply double-click on the iepv.exe file.

IE PassView executable file

The IE PassView main window displays. All passwords you saved in Internet Explorer display in a list with the URL of the website (Entry Name), the Type of password, where the password is stored (Stored In), the User Name and Password pair, and the Password Strength.

IE PassView main window

You can select passwords from the list and save them to various types of files. To do this, select the desired passwords using the Shift and Ctrl keys to select items in the list the same way you would in Windows Explorer. Click the Save Selected Items button on the toolbar.

Saving selected=

NOTE: You can also select items using the Select All and Deselect All options on the Edit menu.

Selecting items using the Edit menu

The Select a filename to save dialog box displays. Navigate to the folder where you want to save your file. Enter a name for your file in the File name edit box. Select the desired file type from the Save as type drop-down list and click Save.

Saving passwords to a text file

NOTE: If you save your passwords to a text file, the passwords are displayed in plain text in that file. If you use KeePass to store your passwords, you can select the KeePass csv file (*.csv) option from the Save as type drop-down list to import the password information into KeePass.

Selecting KeePass .csv file format

If you decide to store your passwords in a text file, we recommend securing the file using encryption. However, your best option is something like KeePass, which is local, or using an online password manager like LastPass.

Text file containing passwords

If you have left IE PassView open while using IE and you have saved more passwords in IE, you can refresh the list in IE PassView by clicking the Refresh button.

Refreshing list of passwords

You can also copy the selected items for pasting into another file by selecting the passwords to be copied and clicking Copy Selected Items on the toolbar. This is useful if you want to securely store the information in a LockNote file, as mentioned above.

NOTE: You can also select Copy Selected Items from the Edit menu.

Copying selected=

You can easily clear your passwords from IE by selecting the passwords you want to delete and clicking Delete Selected Items.

Deleting selected=

A confirmation dialog box displays to make sure you want to delete the selected items. If you delete one password for a website, all passwords from that site will be deleted. Click Yes if you are sure you want to delete the passwords.

NOTE: If other people use your computer, we recommend that you delete all passwords saved in IE before letting someone else use the computer.

Delete confirmation dialog box

There are some options you can set in IE PassView. To set these options, click the Advanced Options button on the toolbar.

NOTE: You can also access Advanced Options from the Options menu.

Selecting Advanced Options

The Advanced Options dialog box displays. You can choose to load the passwords from the currently logged-on user (Load the passwords of the current logged-on user) or from a different user (Load the passwords from the following user profile). If you choose to load passwords from a different user, specify the User Profile Path and the Last Log-On Password for that user. Click OK.

Advanced Options dialog box

If you have a long list of passwords saved, you can search for specific text in the list using the Find option on the Edit menu.

Edit menu

You can customize the display in IE PassView using the options on the View menu. The View menu also allows you to view an HTML Report for all items or only for the selected items.

View menu

To close IE PassView, click the Exit button on the Toolbar or select Exit from the File menu.

Closing IE PassView

NOTE: When dealing with viewing and saving passwords, be very careful. If other people use your computer, you should always encrypt sensitive information. We mentioned some ways to do this earlier in this post. Enjoy!