If you have recently starting using Windows 10, you may have run into an issue where everything starts to run really slow. If you ended up looking at the processes running in Windows 10, you may have noticed a certain process eating up a lot of your CPU.

At least that’s what happened to me on one of my Windows 10 machines. I have installed Windows 10 on several computers and they all worked fine until I installed it on a Lenovo laptop. When I checked the the task manager, I saw that the Device Association Framework Provider Host (daHost.exe) process was taking up almost 90% of the CPU on the system! Normally, it should be at zero and using only a few MBs of RAM.

high cpu dahost

If you’re seeing this running on your system, then the issue could be with an out of date driver running on your system. The process is used for pairing wireless and wired devices to Windows. Since Windows 10 is fairly new and gets updated twice a year, there is still a lot of hardware out there that does not yet support Windows 10 by providing compatible drivers.

You can tell whether it’s hardware causing the problem by going to Device Manager and checking for any yellow exclamation points. You can do this by going to Control Panel and clicking on Device Manager.

device manager

Then check for any yellow exclamation points on network cards, display adapters, etc. If you see one, then it’s definitely related to that piece of hardware and you probably need to find a Windows 10 driver. If you can’t find a Windows 10 driver, try downloading the latest version of the Windows 7 or 8.1 driver. Then you can install it in Compatibility mode.

yellow exclamation

If none of the drivers you are using are working, the only other option you might have until a newer is released is to disable the device. You can do that by right-clicking on the device in Device Manager and choosing Disable.

disable hardware

Of course, you won’t be able to use the device if it’s disabled, but at least you’ll be able to use Windows 10 without the high CPU usage. If you tried all of this or if there is nothing in Device Manager showing a problem, post a comment here and I’ll try to help. Enjoy!